Welcome to the Yamaha Star Bolt Motorcycle Forum

Why join our motorcycle community?

  • Membership is free and easy
  • Get technical support and information for your Yamaha Star Bolt motorcycle or search for information before buying
  • Use the member map to find riders near you
  • Participate in our monthly virtual bike show (or at least vote)
  • Get rid of these annoying boxes asking you to register  ;D

More importantly, make new friends!!

Author Topic: X arc duo wiring  (Read 668 times)

0 Members and 1 Guest are viewing this topic.

Offline craven12

  • Newbie
  • *
  • Posts: 6
X arc duo wiring
« on: March 27, 2021, 10:52:01 pm »
Hi, I installed a set of x arc duo lights and I'm having issues. The pic is the diagram of how I have it wired up. When the bike is not running, everything works good. Running, stop, and turn works as it should. When the bike is running, the brake lights and running lights work, but both turn signals come on no matter if I choose left or right.

Any ideas?
Thanks in advance


2017 R-Spec

Offline lunkhead

  • Hero Member
  • *****
  • Posts: 1675
Re: X arc duo wiring
« Reply #1 on: March 28, 2021, 12:08:56 pm »
Instead of using the blue from the taillight harness, shouldn't you be using the blue from the signal harness? Seems like it only works when the headlight is off (bike not running) so current is feeding back thru it when on.
C-SPƎC

Offline craven12

  • Newbie
  • *
  • Posts: 6
Re: X arc duo wiring
« Reply #2 on: April 08, 2021, 07:57:15 pm »
I have tried using tailight harness and signal harness separately for the running lights, no difference. I even disconnected the brake and running lights leaving just the signals connected and still get the same result. With engine off, signal lights work as it should, as soon as the bike is running, both signals flash when I select either left or right. I sent an email to hightechspeed, and still haven't heard back from them.
This shouldn't be this difficult, lol
2017 R-Spec

  • Advertisement

Offline craven12

  • Newbie
  • *
  • Posts: 6
Re: X arc duo wiring
« Reply #3 on: April 15, 2021, 03:40:09 pm »
I got it sorted out. I had to run load resistors on each light. I'm not sure why, I thought they were for hyper flash. I was running an led flasher that took care of that. When I was still having issues getting the signal lights to work properly, I put the stock flasher in to make sure that wasn't an issue. Then once I put the resistors in everything worked great...Except I now have hyper flash wtf? Thought the resistors took care of that. I will put the led flasher back in and see if it takes care of that.
2017 R-Spec

Offline ShakerNorm

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 5429
Re: X arc duo wiring
« Reply #4 on: June 24, 2021, 10:31:47 pm »
I wonder if a DIODE on the ground wire from each turn signal might be the answer. 
I'm not a Sparky-type, so I'm definitely no expert, though - just an idea.
NOBODY hates winter more than a Canadian Biker!